Segfault Error 4 In Ld 2.13 So

Home > Segfault Error > Segfault Error 4 In Ld 2.13 So

Segfault Error 4 In Ld 2.13 So

All check sums were OK. This cleared the problem. Installed glibc-2.13 -> saw aplay and play segfault Installed glibc-2.12.2 -> still saw aplay and play segfault -> got suspicious ... I then ran the reverse-Depends as suggested above on kate. Check This Out

Libreoffice will start and works for everything except writer. aplay did not segfault, if using some special environment settings. (see above) If I'd be building a new LFS system, I'd rather use glibc-2.13 than glibc-2.14! If you didn't have any updates - yes, by all means. The interesting thing is that Quote: mpg123 -o alsa filename does play w/o any troubles.

especially since you didn't experience these segfaults before, and no one else has either. Something like: aptitude reinstall '?reverse-Depends(libreoffice)~i'; aptitude reinstall '?reverse-Depends(kate)~i'; will do that for you. Something like: aptitude search -F '%p' '?reverse-Depends(libreoffice)~i'|xargs debsums -c; > I then ran the reverse-Depends as suggested above on kate.

Blogs Recent Entries Best Entries Best Blogs Blog List Search Blogs Home Forums HCL Reviews Tutorials Articles Register Search Search Forums Advanced Search Search Tags Search LQ Wiki Search Tutorials/Articles Search > Forums > Linux Forums > Linux - Newbie segfault error User Name Remember Me? I thought it was somehow contained in the lfs base installation, but it seems not. In fact, I had to use a (knoppix) live cd to build my new LFS system as my old system was too old and did not meet the system requirements.

debian-us Gary Roach 2. 2014-10-12 Re: segfaults and error 4 in with soffice. Ran memtest86 for a full day w/ no errors. in dl-lookup.c (gdb) backtrace #0 0xb7fe7c2d in do_lookup_x (new_hash=960564692, old_hash=0xbffff42c, result=0xbffff414, scope=0xb7fdc68c, i=0, flags=2, skip=0x0, undef_map=0xb7fdc530) at dl-lookup.c:98 #1 0xb7fe84f6 in _dl_lookup_symbol_x ( undef_name=0xbffff680 "_snd_config_hook_load_for_all_cards_dlsym_config_hook_001", undef_map=0xb7fdc530, ref=0xbffff4c0, symbol_scope=0xb7fdc700, version=0x0, type_class=0, flags=2, Compulsory unification of opinion achieves only the unanimity of the graveyard. -- Justice Roberts in 319 U.S. 624 (1943) -- To UNSUBSCRIBE, email to [email protected] with a subject of "unsubscribe".

debian-us Gary Roach 4. 2014-10-12 Re: segfaults and error 4 in with soffice. But I did not strip the debugging symbols yet and could possibly help that way, if someone would be willing to do some serious tutoring with me. ;-) I'm kind of If it is not in the man pages or the how-to's this is the place! One more thing seems to be pointing towards glibc as the guilty one here: been running aplay thru gdb and I've got this: Code: Starting program: /opt/devel/packages/base/_audio/alsa/alsa-utils- [Thread debugging using libthread_db

lrwxrwxrwx 1 root root 12 30. Or maybe that would solve it and point the links to the newest remaining version of glibc? (Preferably helpful) feedback is welcome. I'm rather ill prepared / ignorant / inexperienced to investigate such a thing on my own. If either is yes, investigate there.

aptitude reinstall '?reverse-Depends(libreoffice)~i~not(~name(dpkg))' You might have to repeat the ~not() bit if there are other packages involved in a dependency cycle. -- Don Armstrong Those who begin coercive elimination of his comment is here aquaboot *BSD 4 12-08-2007 04:45 PM broke gentoo after installing alsa-driver & alsa-utils snakeo2 Linux - Newbie 1 01-26-2006 08:05 AM [ALSA 1.0.9b-4] No more sound, no more alsa-utils package Creak I believe, you certainly are right about, that a bug report should be filed. Note that registered members see fewer ads, and ContentLink is completely disabled once you log in.

Contact Us - Advertising Info - Rules - LQ Merchandise - Donations - Contributing Member - LQ Sitemap - Main Menu Linux Forum Android Forum Chrome OS Forum Search LQ How can I fix it? For more advanced trainees it can be a desktop reference, and a collection of the base knowledge needed to proceed with system and network administration. You are currently viewing LQ as a guest.

drwxr-xr-x 7 root root 4096 22. Libreoffice still doesn't work. You are currently viewing LQ as a guest.

It happened again.

lol What this wanted to teach me, probably was, that you could not change the glibc-version of a system, without rebuilding it, or some very similar lesson. Kate now works fine. Still, I seem to be able to utilize " ->" in a glibc-2.14 system and thereby get rid of the problems mentioned above. :-) Marlino View Public Profile View Reply to: Gary Roach (on-list) Gary Roach (off-list) Follow-Ups: Re: segfaults and error 4 in with soffice.bin and kate From: Gary Roach Re: segfaults and error 4 in

CrunchBanger From: Sofia, Bulgaria Registered: 2012-08-12 Posts: 209 Re: [SOLVED]Segmentation Error (Read if applications crash or wont open) Looks like false install, or corrupted installation image. It's quite possibly that your bad drive had a bad sector or similar in one or more of these programs... I was able to do other things in the system and tried to login with another putty session but just couldn't. Aky^ View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by Aky^ 07-27-2011, 09:00 AM #5 Marlino LQ Newbie Registered: Jul 2011 Location:

Reason: corrected possibly misleading typing error Marlino View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by Marlino 07-29-2011, 07:23 PM #8 Marlino Even the test suites run OK. android. I pressed the reset button and got a whole bunch of segfault error and it didn't come up.

Linux- was the only kernel I used with the system in question. unSpawn View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by unSpawn View Blog 01-13-2009, 05:55 PM #3 GaijinPunch Member Registered: Aug 2003 Click Here to receive this Complete Guide absolutely free. Couldn't compile anything that took more than a few minutes w/o a segmentation fault.

I got a script somewhere (forgot where... The time now is 08:08 AM. Could it be a thermal issue like Tinkster mentioned? Offline #6 2014-01-10 12:27:38 Kriogenic New Member Registered: 2014-01-09 Posts: 8 Re: [SOLVED]Segmentation Error (Read if applications crash or wont open) I updated this post to be the REAL cause of

If this is happening on a fresh install follow step 4 also1) Make a CrunchBang live USB or CD and get to the boot menu and choose memtest.2)Let memtest run and I'm tempted to rule out the kernel version as being the problem, as the only kernel header included from aplay.c is something which should be invariant for a given CPU architecture